Teraz jest wtorek, 14 sierpnia 2018, 13:01




Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 
 ProCoder DVD 
Autor Wiadomość
Aktywny bywalec
Aktywny bywalec
Post ProCoder DVD
Jakie ustawienia dajecie dla Mpeg2-DVD 6M/s
w programie ProCoder chodzi mi o:
1.Desired Pixel Aspect Ratio -
2.Interlacing -
3.cbr/vbr -
Ja mam problem : na obrazie mam zniekształcenia przy szybim ruchu
obiektów np tańcząca para /mrowienia lub kwadraty/

prosze o podpowiedz jeśli ktoś eksperymentował z tym programem


poniedziałek, 14 lipca 2003, 14:13
Aktywny bywalec
Aktywny bywalec
Post Przeplot
Prawdopodobnie zakodowałeś obraz z przeplotem jako bez przeplotu (progressive).
Jeśli materiał pochodzi z kamery cyfrowej albo z analoga i posiada przeplot - czyli w większości przypadków - to również kodowanie musi odbywać się z przeplotem.
Skąd wiadomo że materiał ma przeplot? Na komputerze wyświetl jedną klatkę w której widać szybki poziomy ruch (w skali 1:1). Na obrzeżach takiego obiektu powinny pojawić się "ząbki". Linie parzyste zawierają obraz z jednej części klatki, a nieparzyste z drugiej. Przesunięcie czasowe występujące podczas rejestrowania obrazu skutkuje tym że na obu tych częściach klatki obraz jest ciut inny więc połączenie klatki w całość skutkuje takim efektem.
A więc kodując film do mpeg2 musimy tak skonfigurować program aby rozdzielił klatkę na 2 częsci (z liniami parzystymi i nieparzystymi) i żeby każdą z nich zakodował osobno.
Inaczej program weźmie klatkę taką jaka jest i zastosuje swoje algorytmy do takiego poszatkowanego obrazu, przez co pojawi się mnóstwo błędów, kwadratów itd..

Jest jeszcze jeden dylemat. Półobrazy składające się na jedna klatke filmu wyświetlane są z różną kolejnością. Raz te z liniami parzystymi później z nieparzystymi - albo na odwrót. I to musisz ustalić. Półobrazy nazywane są z reguły jako A i B.
Przy ustawieniach przeplotu (iterlace) musisz z reguły ustalić kolejność). Na poczatku na krótkim filmie zrób na próbę 2 kodowania i porównaj wyniki. Źle ustawiona kolejność półobrazów charakteryzuje się tym że poruszające sie obiekty na filmie zaczynają skakać...

Polecam pokombinowanie z ustawieniami.

Pozdrawiam

emes

PS. CBR - to stały bitarte dla całego filmu (ilość danych na każdą klatkę jest stała - bardziej szczegółowe ujęcia oraz te małoszczegółowe dostaja tyle samo bitów. Jaki to rodzi konsekwencje to chyba pisać nie muszę).
VBR - program dobiera właściwą ilość bitów analizując skomplikowanie sceny. Może się zdarzyć tak że film będzie łatwy i kodek użyje niskich wartości i plik będzie mały - albo i tak że film będzie ciężki i kodek przez większość czasu uzywać będzie max bitrate. Wadą vbr jest to że trudno przewidzieć wielkość końcową pliku.

Pixel aspect ratio - to współczynnik proporcji wyświetlanego piksela. Przy filmach na DVD, VCD, SVCD piksel nie jest kwadratowy.
720x576 to nie 4/3. I żeby to był 4/3 to obraz trzeba rozciągnąć.
Przy DVD jest to umowne rozciągnięcie do 768x576 (4/3) o około 6,5%.
Z reguły zapisuje się to jako 1,065... I to właśnie jest Pixel aspect Ratio...

Szczególnie widoczne jest to przy SVCD gdzie stosunek szerokości obrazu (480) do wysokości (576) w ogóle jest pokręcony.

Trzeba uważać na ten temat bo różnie jest to określane i różnie trzeba to ustawiać. Znowu kłania się metoda prób i błędów...


poniedziałek, 14 lipca 2003, 15:57
Aktywny bywalec
Aktywny bywalec
Post 
Dziękuje za odpowiedz.
ps. jakich parametrów używasz?


czwartek, 17 lipca 2003, 11:06
Bywalec
Bywalec
Avatar użytkownika

Dołączył: czwartek, 3 kwietnia 2003, 12:31
Posty: 53
Post 
material nagrany kamera cyfrowa i zrzucony jako dv jest ZAWSZE bottom field first (BFF), analogowa z reguly top field first (TFF) (uzywajac kodekow mjpeg lub huffyuv). w razie pomylki i niewlasciwego ustawienia polobrazow zawsze wynikowy plik mpeg-2 mozna przepuscic np. przez Restream, ktory zmieni kolejnosc polobrazow bez ponownej kompresji materialu.


środa, 20 sierpnia 2003, 11:39
Zobacz profil
Aktywny bywalec
Aktywny bywalec
Post A czy ktoś wie
dlaczego ten kodek po parudziesięciu sekundach zwalnia do 1 klatki/s
Mam Win XP , Athlona 2ghz , wgrałem również najnowszego patcha i dalej to samo

dzięki


poniedziałek, 8 września 2003, 21:30
Wyświetl posty nie starsze niż:  Sortuj wg  
Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 5 ] 


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 6 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL