Teraz jest czwartek, 17 stycznia 2019, 07:04




Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 
 Filmik avi przycięty Virtual Dubem nie chce się otwierać 
Autor Wiadomość
Stały bywalec
Stały bywalec

Dołączył: środa, 10 listopada 2004, 10:56
Posty: 68
Lokalizacja: Łódź
Post Filmik avi przycięty Virtual Dubem nie chce się otwierać
Mam filmik z kamerki zapisany w formacie avi. Programik GSpot pokazuje że jest tam kodek H.264/MPEG-4 AVC. Filmik normalnie jest odtwarzany we wszystkich dostepnych odtwarzaczach, np. GOM Player. Przyciąłem za pomocą VB 1.10.4 filmik do fragmentu wybierając w Audio i Video "Direct stream copy". I przycięty filmik otwiera sie, ale bez obrazu. W każdym z odtwarzaczy. GSpot pokazuje, że niezbedne kodeki mam zainstalowane. O co tu może chodzić?


piątek, 26 września 2014, 13:45
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: poniedziałek, 23 stycznia 2006, 15:20
Posty: 2026
Post Re: Filmik avi przycięty Virtual Dubem nie chce się otwierać
Spróbuj przemuxować do innego kontenera, najlepiej do ts albo mts przy pomocy tsmuxer.


piątek, 26 września 2014, 14:16
Zobacz profil
Stały bywalec
Stały bywalec

Dołączył: środa, 10 listopada 2004, 10:56
Posty: 68
Lokalizacja: Łódź
Post Re: Filmik avi przycięty Virtual Dubem nie chce się otwierać
Pinto napisał(a):
Spróbuj przemuxować do innego kontenera, najlepiej do ts albo mts przy pomocy tsmuxer.

Nie udało się , komunikat
"Network Optix tsMuxeR. Version 2.6.12. www.networkoptix.com
Decoding H264 stream (track 1): Profile: Main@5.0 Resolution: 1280:720p Frame rate: not found
H.264 stream doesn't contain fps field. Muxing fps=23.976
H264 bitstream changed: insert nal unit delimiters
H264 bitstream changed: insert pict timing and buffering period SEI units
H264 bitstream changed: insert SPS/PPS units
Decoding H264 stream (track 1): Profile: Baseline@0.2 Resolution: 32:2272i Frame rate: not found"
oraz Error "SPS picture order 23 not supported."


piątek, 26 września 2014, 15:03
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: wtorek, 29 listopada 2011, 19:52
Posty: 355
Post Re: Filmik avi przycięty Virtual Dubem nie chce się otwierać
Spróbuj pociąć w VD filmik do klatek kluczowych, ewentualnie użyj avidemux'a lub mpeg streamclip'a, sądzę, że przyczyną jest cięcie poza klatką kluczową i brak nagłówka, spróbuj naprawić FourCC.
QB

_________________
Teraz a6500, GoPro6, AG-AC160 i parę innych... OSX 10.10, AP CS6.0


piątek, 26 września 2014, 15:56
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: piątek, 6 czerwca 2008, 19:40
Posty: 1258
Lokalizacja: Warszawa
Post Re: Filmik avi przycięty Virtual Dubem nie chce się otwierać
h264 nie jest w pełni kompatybilny z kontenerem avi
http://forum.doom9.org/archive/index.php/t-143613.html

zapisz to VDubem do avi uncompressed, xvid lub mjpeg (poprzez ffdshow)


piątek, 26 września 2014, 16:06
Zobacz profil
Stały bywalec
Stały bywalec

Dołączył: środa, 10 listopada 2004, 10:56
Posty: 68
Lokalizacja: Łódź
Post Re: Filmik avi przycięty Virtual Dubem nie chce się otwierać
Qube napisał(a):
Spróbuj pociąć w VD filmik do klatek kluczowych, ewentualnie użyj avidemux'a lub mpeg streamclip'a, sądzę, że przyczyną jest cięcie poza klatką kluczową i brak nagłówka, spróbuj naprawić FourCC.
QB

Spróbowałem Avidemuxem i poszło :)
Ustawienia : Video: Copy, Audio: Copy, Output Format: Avi Muxer


piątek, 26 września 2014, 17:15
Zobacz profil
Wyświetl posty nie starsze niż:  Sortuj wg  
Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 6 ] 


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 13 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL