Teraz jest piątek, 14 grudnia 2018, 14:35




Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 
 Sony Movie Studio Platinum 13 - problemy z AVCHD 
Autor Wiadomość
Nowy
Nowy

Dołączył: sobota, 8 lutego 2014, 13:10
Posty: 4
Post Sony Movie Studio Platinum 13 - problemy z AVCHD
Od prawie dwóch lat z powodzeniem używam tego programu do obróbki filmów z kamerki Sony HDR-CX260. Nagrywam w formacie 1920x1080/50i, a więc w proponowanym defaulcie. Z kamerki jestem dość zadowolony (nie najlepiej w słabym oświetleniu), z programu i jego rezultatów bardzo. Ale pozostaje kilka wątpliwości. Może ktoś napotkał na podobne do poniższych problemów i lepiej sobie niż ja z nimi poradził? Dodam, że używam komputera z I5 2.6 GHz, 8GB RAM i dyskiem SSD (Lenovo ThinkPad 240) z Windows 7 64b, a więc dość mocnego. Oto problemy:

1. Do zapisu filmu w dobrej jakości testowałem zapis MP4 i AVCHD proponowany przez Sony Movie Studio po kliknięciu na "Utwórz film". Ten pierwszy daje nieco mniejsze pliki, o ok. 10%. Oba zapisane z parametrami proponowanymi (1920x1080, 25 kl, PAL, 16Mb bit rate). Ze zdziwieniem stwierdziłem, że filmy w formacie AVCHD są lepsze (płynniej się odtwarzają, mniejsze szumy). Ze zdziwieniem, bo przecież kodeki video są takie same. Próbowałem zmieniać parametry zapisu przy MP4, ale wciąż widzę różnice na korzyść AVCHD. Może coś źle robię? Przy odtwarzaniu widzę jednak, że MP4 odtwarza się z prędkością 25 kl/s, AVCHD - 50 kl/s, pomimo że oba miały na wejściu ustawione 25. Może to to tłumaczy różnicę? Choć na ostrość (kompresja) nie powinno mieć wpływ.

2. Zdecydowałem się więc na zapis w formacie AVCHD. Niestety przy dłuższych filmikach, tak powyżej 1.5GB, podstawowy odtwarzacz Windows Media Player, który działa płynnie przy mniejszych plikach, zawiesza się począwszy od pewnego miejsca filmu. Próbowałem różnych, m.in. Potplayera, ale najlepiej się sprawdza MPC-HC. Nie ma problemów z odtwarzaniem nawet długich filmów, ale też jest bemol. Przy szybkim przewijaniu, długo się czeka na powrót głosu. Im dalej w filmie tym dłużej. Pewnie jest to związane ze sposobem zapisu głosu w kontenerze AVCHD. Trochę denerwujące. Przy odtwarzaniu MP4 problem nie występuje.

3. Próbowałem wstawiać na youtube najlepsze wersje AVCHD i MP4. Na szczęście youtube dobrze łyka AVCHD. Po przetworzeniu znów wydaje mi się, że wersja youtube pochodząca z AVCHD jest lepsza od tej MP4, ale różnica nie jest porażająca.

Reasumując. Wybieram najlepszą możliwą wersję zapisu AVCHD. Pomimo dużej wielkości (30 min daje ok. 4GB), korzystam z niej również do wysyłki na youtube. Trochę mnie denerwuje opisany problem z głosem przy przewijaniu filmu i brak zrozumienia skąd biorą się różnice jakości między zapisem AVCHD i MP4.


czwartek, 1 października 2015, 15:53
Zobacz profil
Aktywny bywalec
Aktywny bywalec
Avatar użytkownika

Dołączył: poniedziałek, 31 maja 2010, 11:05
Posty: 1906
Lokalizacja: Opole
Post Re: Sony Movie Studio Platinum 13 - problemy z AVCHD
Użyj VLC, bo najprawdopodobniej masz problemy z kodekami i dla tego obraz ma opuźnienie względem dźwięku.
Parametry plików odczytasz MediaInfo w widoku HTML(w innych też, ale z tego dobrze się kopiuje). Jeśli oczekujesz odpowiedzi to warto podawać parametry zamiast "lepiej, najlepiej, gorzej" bo choć na pewno trafne, to jednak tylko Twoje obserwacje, które nie ma do czego porównać.

_________________
Obrazek


czwartek, 1 października 2015, 16:05
Zobacz profil
Nowy
Nowy

Dołączył: sobota, 8 lutego 2014, 13:10
Posty: 4
Post Re: Sony Movie Studio Platinum 13 - problemy z AVCHD
robertnik napisał(a):
Użyj VLC, bo najprawdopodobniej masz problemy z kodekami i dla tego obraz ma opóźnienie względem dźwięku.
Parametry plików odczytasz MediaInfo w widoku HTML(w innych też, ale z tego dobrze się kopiuje).


VLC był jednym z pierwszych odtwarzaczy, które próbowałem. Nie pamiętam już szczegółów, ale nie byłem z niego zadowolony. Parametry moich plików MP4 i AVCHD są bardzo zbliżone, by nie powiedzieć te same. Kodeki (najnowsze) używam z pakietu K-Lite. Z niego też pochodzi odtwarzacz MHC-HC (Media Player Classic). Gdyby nie to opóźnienie dźwięku w stosunku do obrazu, ale tylko po szybkim przewijaniu, byłoby idealnie.


piątek, 2 października 2015, 12:03
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: wtorek, 28 sierpnia 2007, 07:51
Posty: 7231
Lokalizacja: wawa
Post Re: Sony Movie Studio Platinum 13 - problemy z AVCHD
"Kodeki (najnowsze) używam z pakietu K-Lite"

ludzie się nigdy nie nauczą


piątek, 2 października 2015, 13:12
Zobacz profil
Aktywny bywalec
Aktywny bywalec
Avatar użytkownika

Dołączył: poniedziałek, 31 maja 2010, 11:05
Posty: 1906
Lokalizacja: Opole
Post Re: Sony Movie Studio Platinum 13 - problemy z AVCHD
Masz źle skonfigurowane kodeki. Nie jest ważne czy są nowe, czy stare. Wyłacz wspomaganie HW bo to one najczęsciej powoduje krzaki, lub skonfiguruj je prawidłowo.
Nie klikanie kolejno OK przy instalacji niczego nie konfiguruje. Jak nie umiesz to nie używaj. O VLC pisałem dla tego że ma je wbudowane i skonfigurowane, nie najlepiej, ale wystarczająco dobrze by po prostu działał.

_________________
Obrazek


piątek, 2 października 2015, 13:39
Zobacz profil
Nowy
Nowy

Dołączył: sobota, 8 lutego 2014, 13:10
Posty: 4
Post Re: Sony Movie Studio Platinum 13 - problemy z AVCHD
robertnik napisał(a):
Masz źle skonfigurowane kodeki. Nie jest ważne czy są nowe, czy stare.


Może są i źle skonfigurowane. Jeszcze raz przeinstalowałem, wydaje mi się, że wszystko zrozumiałem i dobrze wybrałem. Wszedłem też w konfiguracje. Nie są to żadne cuda. Jeśli czegoś nie rozumiem, google szybko podpowiada. Trochę poeksperymentowałem z różnymi ustawieniami. Ale problem nie ustąpił. Dodam jednak, że nie jest to duży problem. Po szybkim przewinięciu filmu w MPC-HC pod koniec 30 minutowego filmu AVCHD muszę poczekać kilkanaście sekund na pojawienie się głosu. Jeśli niczego nie dotykam film odtwarza się prawidłowo, zarówno video jak i audio. Z filmami MP4 nie ma żadnych problemów.

Bardziej interesują mnie niezrozumiałe dla mnie różnice jakości miedzy AVCHD i MP4, o których pisałem w 1. punkcie.


piątek, 2 października 2015, 15:37
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: poniedziałek, 23 stycznia 2006, 15:20
Posty: 2025
Post Re: Sony Movie Studio Platinum 13 - problemy z AVCHD
AndrzejOz napisał(a):
(...)przecież kodeki video są takie same.

To, że kodeki są takie same, nie oznacza, że są te same.


piątek, 2 października 2015, 17:56
Zobacz profil
Wyświetl posty nie starsze niż:  Sortuj wg  
Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 7 ] 


Kto przegląda forum

Użytkownicy przeglądający to forum: Google [Bot] i 5 gości


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL