Teraz jest sobota, 11 lipca 2020, 08:05




Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 15 ] 
 Problem z płynnością w trakcie montażu iMovie 
Autor Wiadomość
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Problem z płynnością w trakcie montażu iMovie
Witam serdecznie,
Jako, że jestem laikiem (aczkolwiek kilka filmów rodzinnych już zrobiłem i są całkiem ok), postanowiłem zwrócić się o pomoc do specjalistów.
Mianowicie, mam problem z płynnością plików wideo podczas montażu w iMovie. Większość plików mam z kamery Sony HDR-CX 115 (więc już dość wiekowy model, ale jeszcze daje radę). Jako, że teraz jest trochę czasu, postanowiłem zrobić porządek i zmontować kilka rodzinnych filmów. Ostatnio jak działałem (jeszcze na dysku talerzowym, jakieś pół roku temu) było wszystko ok, natomiast dzisiaj okazało się, że podczas montażu film bardzo skacze, tak, że praktycznie nic się nie da z tym zrobić. Nagranie jest w formacie AVCHD-MPEG2, więc nie jakieś szczególnie wymagające. W czym może być problem?
Tak to wygląda: https://wrzucplik.pl/pokaz/2001360---mfbi.html

Żeby było ciekawiej, inne nagranie, pochodzące np. z drona DJI Spark (MPEG-4) odtwarzane jest płynnie. Wychodzi na to, że problem mam tylko z filmami pochodzącymi z kamery Sony (a to zdecydowana większość).
Dla porównania: https://wrzucplik.pl/pokaz/2001361---ftqm.html

Sprzęt na którym pracuję to iMac 21,5 Late 2013 8 GB ram, dysk jakieś pół roku temu wymieniony na ssd. System osx to Catalina. Sprawdziłem działanie również na Macbooku Pro (2012) z 16 GB ramu, z dyskiem ssd i występuje dokładnie taki sam problem. Więc to raczej problem software. Może to kwestia jakichś kodeków? Tylko nie bardzo rozumiem, bo wcześniej było wszystko ok, a nic nie zmieniałem w ustawieniach. Postawiłem czysty system i jest tak samo.

Załączone pliki widzę, że nie chcą się otwierać na stronie, ale można pobrać i odtworzyć, format *.mov

Pomóżcie, bo naprawdę skończyły mi się pomysły.


środa, 8 kwietnia 2020, 10:45
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: niedziela, 27 grudnia 2009, 21:26
Posty: 1300
Post Re: Problem z płynnością w trakcie montażu iMovie
Nie pracuję na Macach i nie rwę się do pomocy w tym zakresie - ale tak pomyślałem - kiedy zmieniłeś OS na Catalinę, bo raczej musiałeś uaktualnić biorąc pod uwagę generacje sprzętu?
Czy nie jakoś " w międzyczasie ", czyli w okresie pomiędzy poprzednimi montażami a obecnym podejściem? Może przy okazji wymiany dysku?

Pytam, bo przejście ze starszych systemów na Catalinę to również zmiana środowiska na 64-bitowe i ma to wpływ na funkcjonowanie iMovie. A dokładnie na możliwości rekompresji, które wcześniej były dokonywane "wewnątrz" iMovie, a pod Cataliną nie są realizowane. I zredukowało to liczbę kodeków obsługiwanych w programie. Takie info znalazłem na supporcie Apple.


czwartek, 9 kwietnia 2020, 20:20
Zobacz profil
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Re: Problem z płynnością w trakcie montażu iMovie
Dokładnie tak, w międzyczasie zmieniłem dysk i uaktualniłem system. Wczoraj jednak zrobiłem downgrade do poprzedniej wersji (Mojave) i dalej było to samo. Tyle, że wersja iMovie była identyczna. Ale w Catalinie, po dodaniu klipu na timeline i kilkukrotnym odtworzeniu (ok. 10 razy) zaczyna działać płynnie. Natomiast kolejny klip po dodaniu dalej klatkuje i żeby było płynnie, trzeba odtworzyć znowu z 10 razy. Tak nie da się działać, jest to ogólnie bardzo zagadkowe.

Zgłosiłem problem do supportu Apple, wysłałem nagranie i mają przekazać do swoich inżynierów (na stronie jest info, że ta kamera bez problemu powinna z programem współpracować). Dla porównania zainstalowałem Davinci Resolve i tam wszystko działa bez problemu. Więc jest to na 95 % problem z iMovie. Mam nadzieję, że uda się to jakoś rozwiązać, bo praktycznie wszystkie nagrania mam z tej kamery, a w iMovie mam zaczętych kilka projektów.


czwartek, 9 kwietnia 2020, 21:18
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: niedziela, 27 grudnia 2009, 21:26
Posty: 1300
Post Re: Problem z płynnością w trakcie montażu iMovie
Jeśli support Appla się tym już zajmuje, to trzymam kciuki żeby pomogli. Ale oczywiście jestem do Twojej dyspozycji, jeśli okaże się, że materiał z kamery trzeba konwertować a fachowcy Ci nic konkretnego nie polecą - to poszukamy. Bo kamera, jak zerknąłem, filmuje chyba wyłącznie z przeplotem obrazu, a to czasem bywa kłopot zwłaszcza w łączeniu z natywnie progresywnymi klipami.

Tymczasem podam Ci linki do informacji, które znalazłem:

https://support.apple.com/pl-pl/HT209029

https://support.apple.com/pl-pl/HT209029#supported_formats

EDIT
Dokładniej jeszcze raz przeczytałem co piszesz, i może jest tak że dokonuje się rekompresja "w tle" do obsługiwanego kodeka czy intermediaty ProResa i po prostu trzeba komputerowi pozwolić popracować, a po ukończeniu conformingów odtwarzanie będzie już płynne? Taka hipoteza.
Sorki, piszę trochę chaotycznie, ale przez tę zarazę to taki zap***dziel, że między myciem rąk a myciem rąk to człowiek mało co zdąży zrobić! :lol:


czwartek, 9 kwietnia 2020, 22:35
Zobacz profil
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Re: Problem z płynnością w trakcie montażu iMovie
Dzięki serdeczne, odpowiedź z Apple mam dostać maksymalnie do tygodnia, tymczasem może faktycznie wrzucę kilka klipów na timeline i zostawię na jakiś czas. Jednak wcześniej po takim zabiegu mogłem w zasadzie natychmiastowo działać (dzielić, łączyć itp.).
U mnie już się taki bałagan zrobił w klipach (prawie 4TB na dyskach zewnętrznych), że chciałem w tym czasie trochę porządku zrobić, a tu klops.
Ale nic, mam nadzieję, że uda się temat ogarnąć, bo kiedyś całkiem nieźle mi to wychodziło :)

EDIT
Zrobiłem jak pisałeś, wrzuciłem klip na timeline, przy próbie pierwszego odtworzenia, efekt jak wcześniej, ale zostawiłem komputer i ku mojemu zdziwieniu, po ok. 8 minutach klip odtwarza się bez zająknięcia! Więc chyba faktycznie chodzi o ką rekompresię w tle. Ale klip na długiść 2,4 min., więc jak ja mam czekać po wrzuceniu klipu na timeline 4 razy dłużej niż on trwa, to ja do końca życia nie zmontuję tych moich filmów. W każdym razie problem sie chyba krystalizuje. Ale może da się to jakoś przyspieszyć, bo jak pisałem, wcześniej dało się pracować niemalże natychmiastosowo po wrzuceniu klipów na oś czasu.


czwartek, 9 kwietnia 2020, 23:01
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: niedziela, 27 grudnia 2009, 21:26
Posty: 1300
Post Re: Problem z płynnością w trakcie montażu iMovie
OK, poczekajmy na reakcję chłopaków z jabłuszka, bo ja niewiele mogę się w temacie powymądrzać. Napisz, bo sam jestem ciekaw jak będzie sollucja. :D


czwartek, 9 kwietnia 2020, 23:26
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: niedziela, 27 grudnia 2009, 21:26
Posty: 1300
Post Re: Problem z płynnością w trakcie montażu iMovie
A! Jeszcze może tak być, że komputerek pracuje nad tymi wcześniej wprowadzonymi do projektu plikami, i stąd taki mało dziarski z nowo dodanymi?
Może nie mam racji, ale spróbuj go zostawić na noc niech działa. A nuż rano będzie lepiej... :roll:


czwartek, 9 kwietnia 2020, 23:38
Zobacz profil
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Re: Problem z płynnością w trakcie montażu iMovie
Odezwał się dzisiaj przedstawiciel Apple, chyba temat jest głębszy niż by się wydawało, bo poprosił o dodatkowe informacje, nagrał pulpit itp. Problemem jest najprawdopodobniej iMovie, we wtorek mam mieć odpowiedź, ale pewnie skończy się na wprowadzeniu po cichu jakiejś łatki. Jak sam przyznał nie powinno to funkcjonować w ten sposób. Zobaczymy, co wymyślą...


czwartek, 16 kwietnia 2020, 20:25
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: niedziela, 27 grudnia 2009, 21:26
Posty: 1300
Post Re: Problem z płynnością w trakcie montażu iMovie
Mam nadzieję, że wymyślą a nie będą zwodzić i udawać.
Rozumiem, że odczekanie aż komputer czy raczej iMovie sam sobie to uporządkuje nic nie dało.
Ja niestety siedzę w Windows i raczej już nic mądrego Ci nie wymyślę.
Trzymam kciuki.


czwartek, 16 kwietnia 2020, 21:11
Zobacz profil
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Re: Problem z płynnością w trakcie montażu iMovie
Czekanie, aż iMovie samo uporządkuje materiał to pewne rozwiązanie pośrednie. Owszem, jeśli wrzucę wszystkie klipy projektu na timeline, zostawię w spokoju komputer, to bo pewnym (mocno dłuższym) czasie zaczyna to działać płynnie. Natomiast, chcąc dorzucić kolejny klip do projektu, znowu muszę czekać.
Sam konsultant Apple przyznał, że nie tak to powinno funkcjonować. W innych programach nie ma z tym najmniejszego problemu.
Zrobiłem jeszcze jeden test: wyrzuciłem wszystkie rozpoczęte projekty z iMovie (przeniosłem na dysk zewnętrzny) i na "czystym" programie utworzyłem nowy projekt. Dodałem jeden klip 2-minutowy i... na początku efekt ten sam, a po kilku minutach dopiero zaczęło działać płynnie. Więc ewidentnie iMovie w tym czasie pracuje i coś tam przetwarza, tylko dlaczego tak długo? Mam nadzieję, że znajdą rozwiązanie, bo wcześniej przecież wszystko działało jak powinno.


piątek, 17 kwietnia 2020, 06:44
Zobacz profil
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Re: Problem z płynnością w trakcie montażu iMovie
Odezwał się przedstawiciel Apple. Poinformował mnie, że sprawa zostanie rozwiązana przez wprowadzenie tzw. "cichej łatki", albo przy najbliższej aktualizacji oprogramowania, czyli... w zasadzie nie wiadomo kiedy. Powiem szczerze, że jakoś tak czułem taką odpowiedź. Krótko mówiąc, mamy cię w d....... i radź sobie sam.


piątek, 17 kwietnia 2020, 15:31
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: niedziela, 27 grudnia 2009, 21:26
Posty: 1300
Post Re: Problem z płynnością w trakcie montażu iMovie
Ech, te korporacje... wszędzie to samo.
Może w tej sytuacji jest sens konwertować pliki z kamery? Myślę że klipy w ProResie iMovie powinno obsługiwać bez zwłoki.


piątek, 17 kwietnia 2020, 20:27
Zobacz profil
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Re: Problem z płynnością w trakcie montażu iMovie
Podpowiesz czym najlepiej? Bo na tą łatkę to chyba przyjdzie mi poczekać...


niedziela, 19 kwietnia 2020, 22:01
Zobacz profil
Aktywny bywalec
Aktywny bywalec

Dołączył: niedziela, 27 grudnia 2009, 21:26
Posty: 1300
Post Re: Problem z płynnością w trakcie montażu iMovie
Jeśli nie masz Compressora zainstalowanego, to może wypróbuj maczkową wersję VideoProc, ściągnij triala najpierw i zobacz jak się sprawuje. Powinie z integry w procku korzystać.
https://www.videoproc.com/guide/tech-specs.htm


poniedziałek, 20 kwietnia 2020, 06:30
Zobacz profil
Nowy
Nowy

Dołączył: środa, 8 kwietnia 2020, 10:21
Posty: 8
Post Re: Problem z płynnością w trakcie montażu iMovie
Dzięki serdeczne, będę walczył :)


poniedziałek, 20 kwietnia 2020, 20:04
Zobacz profil
Wyświetl posty nie starsze niż:  Sortuj wg  
Stwórz nowy wątek Odpowiedz w wątku  [ Posty: 15 ] 


Kto przegląda forum

Użytkownicy przeglądający to forum: Google [Bot] i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  
Powered by phpBB © phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL